News,Symbian

Fix for Swype for Symbian is available

26 Nov , 2012  

Yesterday, Swype for Symbian’s beta expired and stopped working as we reported. Update was unlikely from the developer, but great community has finally managed to find a fix for it.

varfolomey on Daily Mobile Forum has patched the dlls to update the expiration date for the beta build and as he stated, he updated year to 2099!

Quoting him:

Swype was programmed to work until today, now it is useless and hangs whole the system
http://betalabs.nokia.com/trials/swype-for-symbian-2-0/bugreport/version-old-swype-gestures-not-working
Since no update is coming we need to try to patch some dlls ourselves.

Only unpacked PenInputLayoutPluginSwype.dll contains a date – oct 19 2011 (screen)
This is a date when package was build (screen2)
I tried to put 2012 instead of 2011, but that didn`t help
Any suggestions?  Smiley

So I managed to fix Swype at last. I was correct about 2011 in a first place. My mistake was that I packed modded Dll and Swype didn`t start. Just now I decided not to pack it and it worked. I changed date to 2099.

FIX
put file into c/sys/bin folder and restart

if you have swype installed on E drive, you should put file into e/sys/bin and hash file into c/sys/hash

 S^3 varf.zip
 s60v5 varf.zip
 S^3 hash file.zip
 S60v5 hash file.zip

Big thanks to him for a quick fix. This is just an another example of how great community never lets Symbian or MeeGo die (completely).

Thanks @vin2ktalks for taking it to our notice. 🙂

Source: Daily Mobile Forum

, , , , ,